平素は格別のご高配を賜り、厚く御礼申し上げます。
この度は、ご利用いただいております「勤労の獅子」の打刻取込遅延障害において
ご迷惑をお掛け致しました事、深くお詫び申し上げます。
本メールにて障害内容の原因、再発防止策についてご報告いたします。
事象:
以下の期間に「勤労の獅子」の打刻端末で打刻した打刻情報が
2021年12月14日12:00頃まで勤怠データ及び弁当・食事データへ反映されませんでした。
2021年 12月13日(月)19:27頃から
2021年 12月14日(火)12:00頃まで
影響:
「勤労の獅子」の一部環境において、以下の影響がございました。
・期間内に打刻端末で打刻した出勤、退勤などの打刻情報が勤怠データへ
反映されませんでした。
・期間内に打刻端末で打刻した弁当の注文情報が弁当データへ反映されませんでした。
・期間内に打刻端末で打刻した食事の注文情報が食事データへ反映されませんでした。
原因:
想定外な形式の打刻データが存在したことにより、取込処理でエラーが発生しておりました。
そのため、それ以降の打刻情報が取り込まれない状態となっておりました。
データの復旧について:
上記障害発生期間内において、サーバ上に記録されていた打刻情報は
すべて、勤怠データ、弁当データ、食事データへの反映が終了しております。
対策と再発防止策:
・打刻情報の取込処理が失敗した際に、取込処理が中断しないように
プログラムを修正いたします。
・監視システムの設定内容を見直し、即時、障害の調査、対応ができるようにいたします。
また、早急に利用者の皆様へ通知できる体制を構築いたします。
この度は大変ご不便・ご迷惑をおかけし、誠に申し訳ございませんでした。
心よりお詫び申し上げます。お客様に安心してご利用いただけますよう、
サービス品質の向上に努めてまいりますので、今後ともよろしくお願い申し上げます。